Running into error with lilypond

I ran into this error with lilypond not being to work with any script with SCAMP (Or I guess for specifically abjad), however it works with the application frescobaldi. The music playing works perfectly, but it never seems to be able to generate a PDF after playing. The error is as below:

FileNotFoundError: [Errno 2] No such file or directory: ‘lilypond’

from scamp import test_run

That error means that LilyPond isn’t working from the command line. What operating system are you on? Did you install LilyPond directly, or only through frescobaldi?

I am currently on MacOS, and installed lilypond through and followed the instructions from LilyPond Learning Manual: 1.3 Graphical setup under macOS

Where did you put the Lilypond application? It needs to be in Applications for SCAMP to recognize it, I believe

I put lilypond in applications, but when I downloaded it it was a folder instead of an application? I tried to download it again but it would keep downloading the folder. Do I have to drag something out of the folder for it to work?

Interesting; I think they used to distribute an app, and now it’s a folder with a different structure, which is why scamp is not recognizing it.

I’m looking into a fix!